Delays in sending messages through O365 (US data center)
Incident Report for Front
Resolved
We've processed all messages. Everything is back to normal
Posted about 2 months ago. Dec 28, 2017 - 17:12 UTC
Identified
We identified the issue with office and things are going back to normal.
We are currently handling a backlog of messages.
Posted about 2 months ago. Dec 28, 2017 - 16:41 UTC
Investigating
We are currently experiencing delays sending messages through O365. We are actively investigating.
Posted about 2 months ago. Dec 28, 2017 - 15:58 UTC